СЛУЧАЙНЫЕ ПРОЦЕССЫ

Бросание монеты

1 Этап. Постановка задачи

Описание задачи

У вас есть 10 монет. Вы хотите увеличить свой капитал в два раза. Играя с маклером, вы делаете ставку и бросаете монету. Если выпадает “орел”, маклер выдает вам сумму вашей ставки, в противном случае вы ему отдаете эту сумму. Ставка может быть от 1 до 10 монет. Удвоение начального капитала или банкротство приводит к незамедлительному прекращению этого сеанса игры и расчету. Игра может продолжиться по вашему усмотрению.

Цель моделирования

     

  • Варьируя ставки в игре, выяснить, какая тактика чаще приводит к результату (положительному или отрицательному).

     

     

  • Предупредить излишне азартных игроков о невозможности обогащения за счет азартных игр и о степени связанного с ними риска.

     

Анализ объекта

Моделируем игру. Игра – это процесс, в котором участвуют три объекта: игрок, маклер и “случай”, который здесь представлен монетой. Игрок обладает начальным капиталом, который в дальнейшем увеличивается или уменьшается. Другой параметр игрока – величина ставки. Маклер определяет проигрыш или выигрыш игрока, выплачивая выигрыш. Параметром монеты является результат броска – “орел” или “решка”. Случай характеризуется угадываем того, на какую сторону ляжет монета, и имеет два значения -–“угадал” (1) или “не угадал” (0). При этом вероятность выпадения той или иной стороны “половина на половину”.

2 Этап. Разработка модели

Информационная модель

Объект “игрок” имеет управляемые параметры:

  • Ставка количество поставленных на бросок монет;
  • Наличность количество монет у игрока после очередного броска.

имеет неуправляемые параметры (константы):

  • Начальный капитал: 10 монет.

Действия над объектом:

  • Выбор ставки;
  • Вычисление наличности;
  • Продолжение игры.

Объект маклер” имеет управляемые параметры:

  • Бросок определение выигрыша или проигрыша после очередного броска;
  • Выигрыш прекращение игры после увеличения капитала игрока вдвое или больше;
  • Проигрыш прекращение игры после банкротства игрока.

имеет неуправляемые параметры (константы):

  • Нет.

Действия над объектом:

  • Выплата проигранного;
  • Прекращение игры по банкротству.

Объект монета (случай)” имеет управляемые параметры:

  • Положение при приземлении (“орел или “решка”).

имеет неуправляемые параметры (константы):

  • Количество возможных вариантов падения: 2;
  • Вероятность угадывания результата 1/2.

Действия над объектом:

  • Подбрасывание монеты;
  • Определение результата падения.

Логико-математическая модель

Имитировать угадывание результата броска монеты можно с помощью функции СЛЧИС(). Эта функция выдает случайные числа х в диапазоне 0<=x<1. Поскольку вероятность выпадения той или иной стороны Ѕ, то будем считать: если СЛЧИС<0,5 , то результат “угадал” (1), в противном случае – “не угадал” (0). В модели используется логическая функция ЕСЛИ(Условие; ЗначИстина; ЗначЛожь).

Функция угадывания результата при броске имеет вид:

Бросок = ЕСЛИ(СЛЧИС<0,5;1;0),

здесь “1” на выходе функции означает, что игрок угадал, а “0” – не угадал.

Функция изменения наличности игрока:

Наличность = ЕСЛИ(Бросок=1; Наличность + Ставка;

Наличность – Ставка).

Функция определения выигрыша:

Выигрыш = ЕСЛИ(Наличность< 2*Начкапитал; “-“; “банк”),

здесь выдается сообщение “банк” при увеличении начального капитала вдвое или больше, что является условием прекращения игры.

Функция определения проигрыша:

Проигрыш = ЕСЛИ(Наличность>0; “-“; “банкрот”),

здесь выдается сообщение “банкрот” по окончании наличности, что также является условием прекращения игры.

Компьютерная модель

Для моделирования выберем среду электронной таблицы. В этой среде информационная и математическая модели объединяются в таблицу, которая содержит две области:

     

  • исходные данные – константы и управляемые параметры;

     

     

  • расчетные данные (результаты).

     

Задание

Ввести в таблицу исходные данные, а в расчетную часть – следующие формулы в ячейки:

A8: =ЕСЛИ(СЛЧИС()<0,5; 0; 1)

B8: =ЕСЛИ(A8=1; $B$5+$D$5; $B$5-$D$5)

C8: =ЕСЛИ(B8<2*$B$5; “-”; “банк”)

D8: =ЕСЛИ(B8>0; “-”; “банкрот”)

B9: =ЕСЛИ(A9=1; B8+$D$5; B8-$D$5)

При записи формул вставки стандартных функций ЕСЛИ(…) и СЛЧИС(…).

money-cell.xls

III этап. Компьютерный эксперимент

План моделирования

  1. Проверить правильность ввода формул.
  2. Провести расчеты.
  3. Результаты расчетов проанализировать.

Технология моделирования

  1. Ввести в таблицу контрольные данные и расчетные формулы в первую строку.
  2. Скопировать формулы в нижестоящие ячейки в обозримом пространстве экрана (20 попыток)

Появление в столбце “Выигрыш” сообщения “банк” означает удвоение наличности, а в столбце “Проигрыш” сообщения “банкрот” - нулевую наличность. И то и другое приводит к концу сеанса игры.

Следующий сеанс игры проводится в тех же ячейках путем обновления данных 1-го столбца, для чего столбец следует выделить и выбрать команду Заменить по столбцам меню Правка.

IV этап. Анализ результатов моделирования

Привести статистику выигрышей и проигрышей, повторяя игру многократно, и сделать выводы.

возврат к меню процессов